User Tools

Site Tools


spades-software

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
spades-software [2017/12/25 20:46]
aorth
spades-software [2019/10/04 12:58]
aorth
Line 4: Line 4:
 ===== Information ===== ===== Information =====
  
-  * Version: 3.11.1+  * Version: 3.13.0
   * Added: September, 2014   * Added: September, 2014
-  * Updated: December2017 +  * Updated: February2019 
-  * Link: http://cab.spbu.ru/software/spades/+  * Link: https://github.com/ablab/spades
  
 ===== Usage ===== ===== Usage =====
Line 14: Line 14:
 <code>$ module avail spades</code> <code>$ module avail spades</code>
  
-After loading the module, consult the built-in help+Load one version into your environment and run it
-<code>$ spades.py --help</code>+<code>$ module load spades/3.13.0 
 +$ spades.py --help</code>
  
 === Example batch job === === Example batch job ===
Line 24: Line 25:
 #SBATCH -J spades #SBATCH -J spades
  
-module load spades/3.6.1+module load spades/3.13.0
  
 readonly DATADIR=~/data/bfusca readonly DATADIR=~/data/bfusca
Line 45: Line 46:
  
 <code>$ cd /tmp <code>$ cd /tmp
-$ wget  http://cab.spbu.ru/files/release3.11.1/SPAdes-3.11.1.tar.gz +$ wget https://github.com/ablab/spades/releases/download/v3.13.0/SPAdes-3.13.0.tar.gz 
-$ tar xf SPAdes-3.11.1.tar.gz +$ tar xf SPAdes-3.13.0.tar.gz 
-$ cd SPAdes-3.11.1 +$ cd SPAdes-3.13.0 
-$ sudo mkdir /export/apps/spades/3.11.1 +$ sudo mkdir /export/apps/spades/3.13.0 
-$ sudo chown aorth /export/apps/spades/3.11.1 +$ sudo chown aorth /export/apps/spades/3.13.0 
-$ PREFIX=/export/apps/spades/3.11../spades_compile.sh +$ sudo yum install centos-release-scl cmake 
-$ sudo chown -R root:root /export/apps/spades/3.11.1</code>+$ sudo yum install devtoolset-6-gcc.x86_64 devtoolset-6-gcc-c++.x86_64 
 +$ PREFIX=/export/apps/spades/3.13../spades_compile.sh 
 +$ sudo chown -R root:root /export/apps/spades/3.13.0</code>
  
 Note: if you get the error ''Exception caught basic_string::_S_construct null not valid'' you need to call the spades.py script, not the spades binary! Note: if you get the error ''Exception caught basic_string::_S_construct null not valid'' you need to call the spades.py script, not the spades binary!
spades-software.txt · Last modified: 2019/10/04 12:58 by aorth