User Tools

Site Tools


r-software

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
r-software [2020/05/12 13:38]
aorth
r-software [2021/01/25 14:25] (current)
aorth
Line 4: Line 4:
 ===== Information ===== ===== Information =====
  
-  * Version: 3.(3.6.1)+  * Version: 4.(4.0.3)
   * Added: February, 2015   * Added: February, 2015
-  * Updated: October2019+  * Updated: December2020
   * Link: https://www.r-project.org/   * Link: https://www.r-project.org/
  
Line 15: Line 15:
  
 Load one version into your environment and run it: Load one version into your environment and run it:
-<code>$ module load R/3.6+<code>$ module load R/4.0
 $ R</code> $ R</code>
  
Line 26: Line 26:
  
 <code>$ cd /tmp <code>$ cd /tmp
-$ wget https://cran.r-project.org/src/base/R-3/R-3.6.1.tar.gz +$ wget https://cran.r-project.org/src/base/R-4/R-4.0.3.tar.gz 
-$ tar xf R-3.6.1.tar.gz +$ cd R-4.0.3
-$ cd R-3.6.1+
 # install packages to enable capabilities in R # install packages to enable capabilities in R
-$ sudo yum install libX11-devel libXaw-devel bzip2-devel libcurl-devel xz-devel readline-devel glibc-headers+$ sudo yum install libX11-devel libXaw-devel bzip2-devel libcurl-devel xz-devel readline-devel glibc-headers pcre2-devel.x86_64
 # install a newer compiler from Red Hat software collections # install a newer compiler from Red Hat software collections
 $ sudo yum install devtoolset-7-gcc devtoolset-7-gcc-gfortran devtoolset-7-libquadmath-devel devtoolset-7-gcc-c++ $ sudo yum install devtoolset-7-gcc devtoolset-7-gcc-gfortran devtoolset-7-libquadmath-devel devtoolset-7-gcc-c++
 $ scl enable devtoolset-7 bash $ scl enable devtoolset-7 bash
 # R packages are written in C99 and GCC 7 uses a newer standard by default, so tell configure script to use C99 explicitly # R packages are written in C99 and GCC 7 uses a newer standard by default, so tell configure script to use C99 explicitly
-$ export CFLAGS='-std=gnu99  -g -O2' +$ export CFLAGS='-std=gnu99 -g -O2' 
-$ ./configure --enable-R-shlib --prefix=/export/apps/R/3.6+$ ./configure --enable-R-shlib --prefix=/export/apps/R/4.0
 $ make -j4 $ make -j4
-$ sudo mkdir -p /export/apps/R/3.6 +$ sudo mkdir -p /export/apps/R/4.0 
-$ sudo chown aorth:aorth /export/apps/R/3.6+$ sudo chown aorth:aorth /export/apps/R/4.0
 $ make install</code> $ make install</code>
  
 Then install some common libraries used by our users because some of them are quite complicated, and installing them globally saves tens of thousands of header files and libraries being installed into user libraries anyways: Then install some common libraries used by our users because some of them are quite complicated, and installing them globally saves tens of thousands of header files and libraries being installed into user libraries anyways:
  
-<code>$ export LD_LIBRARY_PATH=/export/apps/gdal/2.4.2/lib+<code>/export/apps/R/4.0/bin/
 +> install.packages('sf', repo='https://cloud.r-project.org', configure.args=c(sf = '--with-gdal-config=/export/apps/gdal/2.4.2/bin/gdal-config')) 
 +> install.packages("hierfstat", repos="https://cran.r-project.org"
 +> install.packages("adegenet", repos="https://cran.r-project.org")
 > install.packages("BiocManager", repos="https://cran.r-project.org") > install.packages("BiocManager", repos="https://cran.r-project.org")
-> install.packages("sf", repo="https://cloud.r-project.org", configure.args=c(sf = "--with-gdal-config=/export/apps/gdal/2.4.2/bin/gdal-config")) 
 > install.packages("poppr", repos="https://cran.r-project.org") > install.packages("poppr", repos="https://cran.r-project.org")
-> install.packages("vcfR", repos="https://cran.r-project.org")</code>+> install.packages("vcfR", repos="https://cran.r-project.org") 
 +> install.packages("devtools", repos="https://cran.r-project.org"
 +> library(devtools) 
 +> install_github("HenrikBengtsson/TopDom"
 +> install_github("lucidif/HiCeekR", repos=BiocManager::repositories()) 
 +> q() 
 +$ sudo chown -R root:root /export/apps/R/4.0</code> 
 + 
 +**Note:** some of these packages will need system libraries installed, for example: 
 +  * libgit2-devel.x86_64 
 +  * libjpeg-turbo-devel.x86_64 
 +  * gsl-devel.x86_64
r-software.1589290693.txt.gz · Last modified: 2020/05/12 13:38 by aorth