User Tools

Site Tools


r-software

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
Last revision Both sides next revision
r-software [2019/07/16 06:59]
aorth
r-software [2020/05/12 13:38]
aorth
Line 4: Line 4:
 ===== Information ===== ===== Information =====
  
-  * Version: 3.5.3+  * Version: 3.6 (3.6.1)
   * Added: February, 2015   * Added: February, 2015
-  * Updated: ​July, 2019+  * Updated: ​October, 2019
   * Link: https://​www.r-project.org/​   * Link: https://​www.r-project.org/​
  
Line 15: Line 15:
  
 Load one version into your environment and run it: Load one version into your environment and run it:
-<​code>​$ module load R/3.5+<​code>​$ module load R/3.6
 $ R</​code>​ $ R</​code>​
  
-Here is a good resource on [[https://​www.osc.edu/​resources/​getting_started/​howto/​howto_install_local_r_packages|installing R packages into user libraries]].+Use ''​installed.packages()''​ to check the list of packages installed in the ILRI environment by default. ​Here is a good resource on [[https://​www.osc.edu/​resources/​getting_started/​howto/​howto_install_local_r_packages|installing R packages into user libraries]] ​if you need other packages.
  
 ===== Installation ====== ===== Installation ======
-Notes from the sysadmin during installation:​+Notes from the sysadmin during installation
 + 
 +First, compile the main R application with GCC 7 from Red Hat's ''​devtoolset-7''​ software collection:
  
 <​code>​$ cd /tmp <​code>​$ cd /tmp
-$ wget https://​cran.r-project.org/​src/​base/​R-3/​R-3.5.3.tar.gz +$ wget https://​cran.r-project.org/​src/​base/​R-3/​R-3.6.1.tar.gz 
-$ tar xf R-3.5.3.tar.gz +$ tar xf R-3.6.1.tar.gz 
-$ cd R-3.5.3 +$ cd R-3.6.
-$ sudo yum install ​gcc-gfortran gcc-c++ ​libX11-devel libXaw-devel bzip2-devel libcurl-devel xz-devel readline-devel +# install packages to enable capabilities in R 
-$ ./configure --enable-R-shlib --prefix=/​export/​apps/​R/​3.5+$ sudo yum install libX11-devel libXaw-devel bzip2-devel libcurl-devel xz-devel readline-devel ​glibc-headers 
 +# install a newer compiler from Red Hat software collections 
 +$ sudo yum install devtoolset-7-gcc devtoolset-7-gcc-gfortran devtoolset-7-libquadmath-devel devtoolset-7-gcc-c++ 
 +$ scl enable devtoolset-7 bash 
 +# R packages are written in C99 and GCC 7 uses a newer standard by default, so tell configure script to use C99 explicitly 
 +$ export CFLAGS='​-std=gnu99 ​ -g -O2' 
 +$ ./configure --enable-R-shlib --prefix=/​export/​apps/​R/​3.6
 $ make -j4 $ make -j4
-$ sudo mkdir -p /​export/​apps/​R/​3.5 +$ sudo mkdir -p /​export/​apps/​R/​3.6 
-$ sudo chown aorth:aorth /​export/​apps/​R/​3.5 +$ sudo chown aorth:aorth /​export/​apps/​R/​3.6 
-$ make install +$ make install</​code>​ 
-$ sudo chown -R root:root /​export/​apps/​R/​3.5 + 
-$ sudo yum remove gcc-c++ libX11-devel libXaw-devel bzip2-devel libcurl-devel xz-devel readline-devel</​code>​+Then install some common libraries used by our users because some of them are quite complicated,​ and installing them globally saves tens of thousands of header files and libraries being installed into user libraries anyways:
  
-Note to future Alandon't remove ''​gcc-gfortran''​ after the install ​because some users need it!+<​code>​$ export LD_LIBRARY_PATH=/​export/​apps/​gdal/​2.4.2/​lib 
 +> install.packages("​BiocManager",​ repos="​https://cran.r-project.org"​) 
 +install.packages("​sf",​ repo="​https://​cloud.r-project.org",​ configure.args=c(sf = "​--with-gdal-config=/​export/​apps/​gdal/​2.4.2/​bin/​gdal-config"​)) 
 +> install.packages("​poppr",​ repos="​https://​cran.r-project.org"​) 
 +> install.packages("​vcfR",​ repos="​https://​cran.r-project.org"​)</​code>​
r-software.txt · Last modified: 2020/05/12 18:20 by aorth