User Tools

Site Tools


qiime2-software

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
qiime2-software [2018/05/21 10:01]
aorth
qiime2-software [2018/07/22 19:21] (current)
aorth
Line 4: Line 4:
 ===== Information ===== ===== Information =====
  
-  * Version: 2018.4+  * Version: 2018.6
   * Added: May, 2018   * Added: May, 2018
 +  * Updated: July, 2018
   * Link: https://​qiime2.org/​   * Link: https://​qiime2.org/​
  
 ===== Usage ===== ===== Usage =====
  
-See versions of qiime2 ​which are available:+See versions of qiime2 ​that are available:
 <​code>​$ module avail qiime2</​code>​ <​code>​$ module avail qiime2</​code>​
  
-Load a particular version:+Load a particular version ​into your environment and run it:
  
-<​code>​$ module load qiime2/​2018.4</​code>​+<​code>​$ module load qiime2/​2018.
 +$ qiime --help</​code>​
  
 ===== Installation ====== ===== Installation ======
Line 26: Line 28:
 $ bash Miniconda3-latest-Linux-x86_64.sh -p /​export/​apps/​qiime2/​conda $ bash Miniconda3-latest-Linux-x86_64.sh -p /​export/​apps/​qiime2/​conda
 $ source /​export/​apps/​qiime2/​conda/​bin/​activate $ source /​export/​apps/​qiime2/​conda/​bin/​activate
-$ wget https://​data.qiime2.org/​distro/​core/​qiime2-2018.4-py35-linux-conda.yml +$ conda update -n base conda 
-$ conda env create -p /​export/​apps/​qiime2/​2018.--file qiime2-2018.4-py35-linux-conda.yml +$ wget https://​data.qiime2.org/​distro/​core/​qiime2-2018.6-py35-linux-conda.yml 
-$ conda activate /​export/​apps/​qiime2/​2018.4+$ conda env create -p /​export/​apps/​qiime2/​2018.--file qiime2-2018.6-py35-linux-conda.yml 
 +$ conda activate /​export/​apps/​qiime2/​2018.6
 $ sudo chown -R root:root /​export/​apps/​qiime2 $ sudo chown -R root:root /​export/​apps/​qiime2
 $ qiime --help</​code>​ $ qiime --help</​code>​
  
-Qiime2 has 240 dependencies and is extremely tricky to install without the use of [[https://​conda.io/​miniconda.html|Miniconda]]it is not even published on PyPy anymore, so installing it with pip is not an option. ​install Conda somewhere globally ​so that I can use it to install Qiime2. After the installation is done you don't technically need Conda itself, but Qiime2 ​will need Conda'​s Python so we must keep it around. I compared the output ''​env''​ before and after loading the Qiime2 environment with Conda, then used that to create the module file.+Qiime2 has 240 dependencies and is extremely tricky to install without the use of [[https://​conda.io/​miniconda.html|Miniconda]] ​(it is not even published on PyPy anymore, so installing it with pip is not an option)My strategy is to install Conda somewhere globally ​and then use it to install Qiime2. After the installation is done I think we don't technically need Conda itself ​anymore, but but I will keep it around ​for ease of upgrading and installing future versions. 
 + 
 +To create the [[https://​github.com/​ilri/​hpc-environment-modules/​tree/​master/​qiime2|modulefile]] ​I compared the output ''​env''​ before and after loading the Qiime2 environment with Conda.
qiime2-software.1526886092.txt.gz · Last modified: 2018/05/21 10:01 by aorth