User Tools

Site Tools


abyss-software

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
abyss-software [2018/11/17 23:35]
aorth
abyss-software [2019/07/10 17:25] (current)
aorth
Line 26: Line 26:
 $ tar xf abyss-2.1.4.tar.gz $ tar xf abyss-2.1.4.tar.gz
 $ cd abyss-2.1.4 $ cd abyss-2.1.4
-$ sudo yum install sparsehash-devel.x86_64 ​openmpi-devel.x86_64+$ sudo yum install sparsehash-devel.x86_64 ​openmpi3-devel.x86_64 
 +$ export CPPFLAGS='​-pthread -I/​usr/​include/​openmpi3-x86_64'​ 
 +$ export LIBS='​-Wl,​-rpath -Wl,/​usr/​lib64/​openmpi3/​lib -Wl,​--enable-new-dtags -L/​usr/​lib64/​openmpi3/​lib -lmpi'
 $ ./configure --prefix=/​export/​apps/​abyss/​2.1.4 $ ./configure --prefix=/​export/​apps/​abyss/​2.1.4
 $ make -j4 $ make -j4
Line 33: Line 35:
 $ make install $ make install
 $ sudo chown -R root:root /​export/​apps/​abyss/​2.1.4 $ sudo chown -R root:root /​export/​apps/​abyss/​2.1.4
-$ sudo yum remove sparsehash-devel.x86_64 ​openmpi-devel.x86_64</​code>​+$ sudo yum remove sparsehash-devel.x86_64 ​openmpi3-devel.x86_64</​code>​ 
 + 
 +There is currently a [[https://​github.com/​bcgsc/​abyss/​issues/​224|bug in configure'​s ability to detect the system'​s OpenMPI]] so we have to set the environment variables manually before building.
abyss-software.1542486908.txt.gz · Last modified: 2018/11/17 23:35 by aorth