User Tools

Site Tools


abyss-software

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
abyss-software [2017/10/14 13:39]
aorth
abyss-software [2019/07/10 14:25] (current)
aorth
Line 4: Line 4:
 ===== Information ===== ===== Information =====
  
-  * Version: 2.0.2+  * Version: 2.1.4
   * Added: August, 2013   * Added: August, 2013
-  * Updated: October2017 +  * Updated: November2018 
-  * K-mer size: 64 (default at compile time)+  * K-mer size: 128 (default at compile time)
   * Link: http://www.bcgsc.ca/platform/bioinfo/software/abyss   * Link: http://www.bcgsc.ca/platform/bioinfo/software/abyss
  
Line 16: Line 16:
  
 Load one version into your environment and run it: Load one version into your environment and run it:
-<code>$ module load abyss/2.0.2+<code>$ module load abyss/2.1.4
 $ abyss-pe help</code> $ abyss-pe help</code>
  
Line 23: Line 23:
  
 <code>$ cd /tmp <code>$ cd /tmp
-$ wget http://www.bcgsc.ca/platform/bioinfo/software/abyss/releases/2.0.2/abyss-2.0.2.tar.gz +$ wget http://www.bcgsc.ca/platform/bioinfo/software/abyss/releases/2.1.4/abyss-2.1.4.tar.gz 
-$ tar xf abyss-2.0.2.tar.gz  +$ tar xf abyss-2.1.4.tar.gz 
-$ cd abyss-2.0.2 +$ cd abyss-2.1.4 
-scl enable devtoolset-4 bash +sudo yum install sparsehash-devel.x86_64 openmpi3-devel.x86_64 
-./configure --prefix=/export/apps/abyss/2.0.2 --with-boost=/export/apps/boost/1.65.1/include --with-mpi=/export/apps/openmpi/1.8.2+export CPPFLAGS='-pthread -I/usr/include/openmpi3-x86_64' 
 +export LIBS='-Wl,-rpath -Wl,/usr/lib64/openmpi3/lib -Wl,--enable-new-dtags -L/usr/lib64/openmpi3/lib -lmpi' 
 +./configure --prefix=/export/apps/abyss/2.1.4
 $ make -j4 $ make -j4
-$ sudo mkdir /export/apps/abyss/2.0.2 +$ sudo mkdir -p /export/apps/abyss/2.1.4 
-$ sudo chown aorth /export/apps/abyss/2.0.2+$ sudo chown aorth /export/apps/abyss/2.1.4
 $ make install $ make install
-$ sudo chown -R root:root /export/apps/abyss/2.0.2</code>+$ sudo chown -R root:root /export/apps/abyss/2.1.
 +$ sudo yum remove sparsehash-devel.x86_64 openmpi3-devel.x86_64</code> 
 + 
 +There is currently a [[https://github.com/bcgsc/abyss/issues/224|bug in configure's ability to detect the system's OpenMPI]] so we have to set the environment variables manually before building.
abyss-software.1507988392.txt.gz · Last modified: 2017/10/14 13:39 by aorth