User Tools

Site Tools


abyss-software

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
abyss-software [2014/06/11 00:50]
aorth
abyss-software [2019/07/10 17:25] (current)
aorth
Line 1: Line 1:
 ====== Abyss ====== ====== Abyss ======
-Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler+Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler.
  
 ===== Information ===== ===== Information =====
  
-  * Version: 1.5.1+  * Version: ​2.1.4
   * Added: August, 2013   * Added: August, 2013
-  * Updated: ​June 102014 +  * Updated: ​November2018 
-  * K-mer size: 64 (default at compile time)+  * K-mer size: 128 (default at compile time)
   * Link: http://​www.bcgsc.ca/​platform/​bioinfo/​software/​abyss   * Link: http://​www.bcgsc.ca/​platform/​bioinfo/​software/​abyss
  
 ===== Usage ===== ===== Usage =====
  
-=== See versions of abyss which are available ​=== +See versions of abyss which are available: 
-<​code>​module avail abyss</​code>​+<​code>​module avail abyss</​code>​ 
 + 
 +Load one version into your environment and run it: 
 +<​code>​$ module load abyss/​2.1.4 
 +$ abyss-pe help</​code>​
  
 ===== Installation ====== ===== Installation ======
 Notes from the sysadmin during installation:​ Notes from the sysadmin during installation:​
  
-<​code>​wget ​https://github.com/bcgsc/​abyss/​releases/​download/​1.5.1/abyss-1.5.1.tar.gz +<​code>​$ cd /tmp 
-tar zxf abyss-1.5.1.tar.gz +wget http://www.bcgsc.ca/​platform/​bioinfo/​software/​abyss/​releases/​2.1.4/abyss-2.1.4.tar.gz 
-cd abyss-1.5.1 +tar xf abyss-2.1.4.tar.gz 
-scl enable devtoolset-1.1 bash +cd abyss-2.1.4 
-mkdir /tmp/abyss-build +$ sudo yum install sparsehash-devel.x86_64 openmpi3-devel.x86_64 
-cd /tmp/abyss-build +$ export CPPFLAGS='​-pthread -I/usr/include/​openmpi3-x86_64'​ 
-~/src/abyss-1.5.1/configure --prefix=/​export/​apps/​abyss/​1.5.1 --with-boost=/​export/​apps/​boost/​1.50.0/​include/​ +$ export LIBS='​-Wl,​-rpath -Wl,/usr/lib64/​openmpi3/​lib ​-Wl,​--enable-new-dtags -L/usr/lib64/​openmpi3/​lib ​-lmpi'​ 
-sudo mkdir -p /​export/​apps/​abyss/​1.5.1 +./configure --prefix=/​export/​apps/​abyss/​2.1.4 
-sudo chown aorth /​export/​apps/​abyss/​1.5.1 +$ make -j4 
-sudo chown -R root:root /​export/​apps/​abyss/​1.5.1</​code>​+sudo mkdir -p /​export/​apps/​abyss/​2.1.4 
 +sudo chown aorth /​export/​apps/​abyss/​2.1.4 
 +$ make install 
 +sudo chown -R root:root /​export/​apps/​abyss/​2.1.
 +$ sudo yum remove sparsehash-devel.x86_64 openmpi3-devel.x86_64</​code>​ 
 + 
 +There is currently a [[https://​github.com/​bcgsc/​abyss/​issues/​224|bug in configure'​s ability to detect the system'​s OpenMPI]] so we have to set the environment variables manually before building.
abyss-software.1402437024.txt.gz · Last modified: 2014/06/11 00:50 by aorth